Sunday, February 7, 2016

For Your Other Car #3 - 2007 Honda Odyssey Rear Hub Replacement

At least I'm working on one of my cars!

Around July of last year it was time to replace the tires on my family truckster, the 2007 Honda Odyssey. I'm not a tire guy and believe that rubber is pretty much rubber and the minivan doesn't need anything special. Given that, I looked for the highest-mileage, lowest cost tires I could find. I came across Uniroyal Tiger Paw Touring that were about $110 and had four of them installed for about $510 out the door. Not too bad.

Now, I rarely drive the car and everything was fine as far as I was concerned. Over time, though, I started to notice what sounded like some pretty obvious tire noise. Though it didn't change with different road surfaces (which, in hindsight, didn't make sense), it was annoying as hell. It was a low sort of rumble that changed pitch with the car's speed but it drilled right through your head as it seemed to come from everywhere inside the car. Over time, it got louder and onset at lower speeds but it was still hard to pinpoint location-wise.

Around October, we had some mega-maintenance done on the car for its 100,000-mile birthday. Timing belt, water pump, brake fluid, coolant...just about everything. I had Honda do it and paid dearly for it, but the peace of mind was worth it. Honda noted the tire noise on the work order but didn't mention it further.

Around Christmas, we took a family trip down to Charleston, SC and I thought I was going to have a mental breakdown due to the noise. It's very hard to explain but, like I said, it just drilled through my head. I was determined, when I got back home, to get the tires replaced. I went to the place that I got them and they swapped them out for Hankooks which were similarly priced. I should be getting a full refund on the Uniroyals based on the warranty.

After I picked up the car, I was very angry to discover that the noise had not abated one bit. Guess we were all wrong about the tires. The only other thing back there that rotates is the hub. I did a bit more listening and, sure enough, sitting in the back (instead of driving) I could pinpoint the noise to the rear passenger's side wheel. Armed with that information, I jacked her up, pulled the wheel and turned the hub by hand. Felt like rocks and sand. Did the same on the driver's side and while it was nowhere near as bad, it didn't feel as smooth as I thought it should. Guess 100k miles is about all they are good for. So, hub replacement, here I come.

Turns out, the hubs are little engineering marvels (and pretty cheap, too). They are self-contained units that bolt up directly to the rear suspension. Other designs have them bolt to a center spindle, which seems to be how the 2006 and prior Odyssey's were, but I think this design is much more slick (and I could use my Spitfire-sized torque wrench instead of a 180 ft-lb one)!

Self-explanatory. The hubs I ordered came with the o-ring already installed. Nice.

I also ordered another set of rear pads and two new rotors. The rotors were in pretty bad shape and new ones were only about $20 (from Amazon, if you can believe it!) each. I think they were cheaper than the ones for the Spitfire.

I wanted to do the passenger's side first since it was in imminent failure mode. If I ran into problems, I'd get the one that really needed it done and skip the other. Fortunately, it went as smooth as you would imagine the removal and replacement of only two screws and 13 bolts would go (5 for the wheel, 4 for the brakes, 4 for the hub).

First one. Time to dig in.

You can read in my previous post the the brake caliper is a two-piece design. Two 12mm bolts hold the inner piece (the pad housing) to the outer piece (cage?). I would not have pulled those if I wasn't changing out the pads. Two 17mm bolts held the cage to the car and these were also removed to allow removal of the rotor.

The two 17mm bolts. Note the funky washers. They went between the caliper cage and the mounting bracket on the car.
Once the caliper assembly was removed and wired up out of the way, I removed the two Philips-head screws (I had WD-40'd and smacked those during my previous inspection to loosen them up and they came off easily with a large screwdriver) and removed the rotor.

The hub (the wheel studs are attached) and the parking brake assembly, which did not interfere.
Really glad I made the cheap decision to replace the rotors. I had let the rear pads go too far last time and didn't inspect the rotor all that well. Turns out the inside of the rotors were in horrible shape and just ate the fresh pads right up. Way to go, Chris!

Looks better than it was. There is a good 1/16" drop from the rusty band to the shiny metal.
Then came hub removal. This was the part I was worried about as the hub bolts were at a respectable torque (~70 ft-lbs) and were not that easy to get at.

Picture from behind the assy. The front upper and lower hub bolts (red dots).
But, with a short cheater-bar, I was able to break them all free without rounding them off. The hub pulled right off by hand.

Recess where hub goes in. You can see the bolt holes. That little black square on right is the ABS sensor.
I was careful of the ABS sensor. It must be a magnetic pickup of some sort. On the prior design it was a toothed gear that was monitored by an optical sensor (I assume). There was some minor aluminum corrosion (a white powder) but this was easily brushed out.

Now it was time for the new hub to go in. I set it in and aligned the holes and started all four bolts. I then used a star-pattern, similar for putting on a tire, to evenly draw the hub into its seat so that I wouldn't cut the o-ring (it was already on the new hub, remember). I then torqued each bolt down (star-pattern).

The new hub, awaiting its fate.

All pretty and installed.

Other than that, installation was the reverse of removal and there were no surprises. For good measure, I also adjusted the parking brake. There was the adjusting star wheel at the bottom (sorry, no clear picture) of the parking brake assembly. I turned it until the rotor would not turn, then backed it off 5 tabs. The rotor turned with a very slight rubbing sound.

All done! The black dot is the rubber cover for the parking brake adjustment hole.
After I got that all bolted up and done, it was on to the driver's side. This turned out to be easier because of the reverse direction in leverage (I found it easier to push down to loosen vice pull up...or maybe it was just the practice) and I knocked it out in about 45 minutes. All in all, it took about 2 1/2 hours to do all of the work, including the brakes and the post-work test drive. Darn thing drove like new with no noise. The wife was very happy and, at the end of the day, that's what matters most. Of course, I knew that the hub was eventually going to fail. At the best, it would have left her stranded. At the worse, it could have caused catastrophic damage to the car or even cause an accident.

While I'm sure a Honda mechanic would have easily beat my time, I probably saved about $500 in parts and labor by doing it in my driveway. With another 4-8 inches of snow just forcast for tomorrow into Tuesday, I'm glad I got it done!

For the two or three of you that may check this blog regularly, I apologize for the lack of Triumph work. Unfortunately, the garage thing hasn't materialized and I'm not sure it will. I need to adjust my plan...I just haven't. But, fear not, for I will not give up!

3 comments:

  1. Taking a break is allowed! Don't beat yourself up. Look forward to updates when they come.

    ReplyDelete